NVBDH+ no speed control

Novusun cnc controller
nvum/nvem/nvcm/nvmpg/nvec/SMC4-4-16A16B
lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

NVBDH+ no speed control

Post by lonewolf » Sat Jun 16, 2018 11:45 pm

I just bought an NVBDH+ all the Parameters are set to Default in accordance with DS_NVDB_EN.pdf

This is the Motor I have connected https://www.ebay.com/itm/500W-DC-brushl ... 2622291649

it is connected as follows:
Wire Connection mode:

U: Orange
V: gray
W: Brown

5Vo: Red

HU: white
HV: Green
HW: yellow

COM: Black

when I power it up I get the Beep and a single Red Led on under the cover, and and the normal 4 Dots on the Display.
The Speed Pot is set to 0 and then I press RUN and the Display shows 0 <<== this is normal
Then when I start turning the speed up the display shows 49 Max and the motor is running slow there is no speed adjustment.

I can set the speed POT half way and then hit STOP then hit Run and same 49 shows, I can repeat this several times and sometimes the motor runs up to 200 when this happens then I can turn the speed pot and get the full 5000 RPM from the motor.

So it is an intermittent problem, what could the problem be, I have checked the connector of the display panel and all seems fine ?

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Sat Jun 16, 2018 11:50 pm

I have also changed Parameter P1 and tried it using the CW/CCW start pins and I get the same results as when set in Panel Start Mode


This is the seller I bought from:

https://www.ebay.com/itm/NVBDH-CNC-Brus ... 3558072527

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Sun Jun 17, 2018 3:00 am

OK I tried 1 more test I set the Driver to start/stop on panel and use Analog Voltage for speed input 0-5 VDC

when I press RUN with 0v applied the display shows 0 and the motor does not run <<== Normal

When I apply 3 VDC the motor runs slow at 49 showing on Display, when the voltage is removed the display goes back to 0, then when you re connect voltage sometimes the display only show 49 but other times it shows 300 and motor is running at that speed.

This is telling me there seems to be an ADC problem.

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Mon Jun 18, 2018 8:45 pm

looks like I have the same issue when using PWM input for speed control also with P0 set to 1 for PWM input, I have to toggle the PWM input on and off about 6 times before the driver catches and allows speed above 50 on the display.

it may even be a Firmware Problem or a problem with the DSPIC
DRIVER.jpg
DRIVER.jpg (111.59 KiB) Viewed 3244 times

lollette
Site Admin
Posts: 70
Joined: Wed Jun 06, 2018 8:34 am

Re: NVBDH+ no speed control

Post by lollette » Tue Jun 19, 2018 8:39 am

hi nvbdh+ the seller had test before shiped?

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Tue Jun 19, 2018 3:21 pm

I do not know if the seller tested the Driver before shipping.

I just sent message to them asking them if they tested the device.

I also gave them this link so they could see what the issue is.

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Tue Jun 19, 2018 3:36 pm

it's a nice Driver I like the design and I understand how it works as I am a Retired Electronics Field Engineer.

I do have a PICkit 3 programmer but it has 6 pin connection and this Driver board has only a 5 pin header for programming so I do not know how the driver programming is configured without a Schematic.

I'm just telling you this as if it is a Firmware Issue then I could possibly Re-Flash it.
the signal from the panel and the VSI signal go into the PIC at different places (I traced these out to see if there was a common point)

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Tue Jun 19, 2018 9:58 pm

I can also say that C8 Capacitor is missing from the main board located near the Hall sensor Connector BUT this may be normal as often boards are not fully populated depending on Options.

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Wed Jun 20, 2018 2:27 pm

OK this is Reply from my seller when I ask them if they tested before ship....

New message from: thanksbuyer-hobby Top Rated Seller(11,351YellowShooting Star)
Hi

Can you take photos for the firmware issue so that we can send it to tech worker for check?

Nancy

SO I must conclude that it was not Tested before it was shipped.
I must also Conclude that the seller hasn't looked at the Forum Link I have posted on the issue.

I'm not asking for replacement as my cost to ship it back is almost $30.00 USD it's cheaper for me to just order another one.
I do have the Technical Skills and tools to Fix it.

lonewolf
Posts: 26
Joined: Sat Jun 16, 2018 11:09 pm

Re: NVBDH+ no speed control

Post by lonewolf » Wed Jun 20, 2018 2:52 pm

Thank you again for Responding to my posts, here is copy of last message that I sent to my seller.

New message to: thanksbuyer-hobby
Thank you again for Reply

this is link to the Novusun Manufacture's Help Website, I have posted all information there maybe your Tech can look at what is posted to help see the problem.
viewtopic.php?f=5&t=7

Thank you again
I am not asking for replacement, as it will cost me too much to ship it back, I just need some help to repair what I have I have the Technical Skills to do any repair that it needs after we determine exactly what the problem is.

Post Reply